Posts filed under ‘Tech’

Upgrading to Ubuntu 11.04 without a hitch

  • Go ahead and hit: Alt + F2
  • Type: update-manager -d
  • Perform any additional required updates before install
  • Enter your password, agree to upgrade and such

I did all that, then waited for 45 minutes -  now it is say Error: Forbidden 403, WHAT THE HELL?!

It’s terminal time my friends.

  • type: sudo gedit /etc/apt/sources.list
  • click replace in the search menu
  • Replacehttp://us.archive.ubuntu.comwith

    ftp://us.archive.ubuntu.com

  • Restart your upgrade. Don’t worry no time was lost since it kept all the downloads even though it reverted the installation. Ubuntu so smart.

Have fun and remember.

Fixing Mysterious Motherboard Issue

Last year I upgraded form a Gigabyte board that Jim sent me the previous year, to a Biostar G31-M7 TE.  Along with that, I threw in two larger pieces of memory.  For a long time, I had a mysterious problem with the system.  Every time I would reboot the system, it would only display a blank screen and require the CMOS to be reset in order for it to boot once again. I found this odd, as I had an Asus P4 system that exhibited similar symptoms, only it was fixed by power cycling. Not so in this case. Several months passed with me accepting this error as a daily challenge in life to avoid system reboots. Max uptime was my goal. Most searches into the problem led to video errors or motherboard errors, but as I had a working system after I cleared the BIOS settings, I knew something else was at fault here. I even considered building an external switch to clear the CMOS, I was resetting it so often.

Read the rest of this entry »

Save face after a drunken evening with Last Night Never Happened

lastnightneverhappened

So you started drinking early and put some regrettable images up on Facebook, or really spoke your mind on Twitter.  You could just bury your head in the sand and avoid all those people you said nasty things about, or you can make them appear as if it never occurred with “Last night never happened“.

This “morning after” iPhone app will automatically scrub your Facebook and Twitter account, removing pictures and posts for the time period you specify. It won’t completely save you from your drunken rantings, but it’s a good start.

[via Gizmodo]

Win Macbook Air Via Marissa’s Bunny

Our good friend Marissa’s Dad over at Marissa’s Bunny is at it again.  Due to the fact that he hit his fund-raising threshold,  he was given an 11” Macbook air with 1.4 ghz core 2 duo, 2 GB of RAM, and a 64 gig SSD to giveaway.  That is a great machine!

Even if you would never have bought a Mac for yourself, surely you would feel no shame in winning one.  Would you?

[CLICK HERE TO GO TO HIS SITE TO SIGN UP]

Logitech Web Cam Software Installer Blue Screen Workaround

When installing the software for my new Logitech C910 web cam, my computer started to randomly blue screen, then reboot. During one of these blue screen dumps, I managed to see which file was faulting before the computer restarted.

For some reason, ks.sys was causing the computer to crash, and upon looking into it, I discovered that ks.sys is related to the computer’s sound card. That made sense to me, as the Logitech installer was adding its own microphone drivers to the mix. What didn’t make sense to me was the actual reason behind the blue screens of death.

Upon further investigation and poking around in the Logitech support forums, I found that my Western Digital SmartWare was the culprit. I have a WD Passport drive, which requires the SmartWare application in order to access the hardware-encrypted data on the drive. It seems that the associated services cause the ks.sys fault, for some unknown reason. The only solution that anyone has seemed to come up with is to stop the Western Digital services while the Logitech installer is running, then restart the services afterwards.

So, I did just that, and my installation went off without any more problems. If you are experiencing the same problem, stop the following services before installation, and then restart them afterwards:

WD File Management Engine
WD File Management Shadow Engine
WDDM Service

SQL Express “Missing Instance ID” Workaround

I recently installed SQL Express 2008 and ran into an annoying issue when I later tried to alter the installation.

The initial SQL install went off without a hitch, but the problems began when I tried to add my application. During the installation process, I was prompted to enable full-text indexing on my SQL server. I had no idea this was a prerequisite…shame on me for not reading the application requirements! To add insult to injury, I was not aware that version of SQL Express I was using did not come with full-text indexing as an installable option.

Back to the Internet I went, searching for a copy of SQL Server 2008 Express with Advanced Services. A 500 MB download later, and I was well on my way to getting things running, or so I thought.

I began my SQL installation, choosing to add or change features to my existing install. Everything seemed to be pretty straightforward and painless until I tried to select which SQL installation to upgrade. Each and every time I tried to select the one and only instance on this particular server, I was greeted with the message, “The instance id is required but it is missing”.

I double-checked the installation options I had selected, I ensured that all of the proper services were up and running, plus I even rebooted the server and tried the installation again. However, no matter what I tried, I received the same error each time I attempted to select my SQL instance.

I poked around for awhile, then finally found a solution. First, I went to the Control Panel and selected the Add/Remove Programs console. There, I located the SQL express install and clicked the Change/Remove button. This brought up a slightly different version of the installer interface, from which I could choose an Add option.

Going through the paces, this installer found my existing SQL instance without any issues and I had my SQL Server, complete with full-text indexing in no time!

Geek Speak – ECDSA and the PS3

If you’re like me you’ve been keeping abreast of the recent developments regarding the fail0verflow team’s reverse engineering of Sony’s root signature key. This feat allows the generation of signed homebrew code which can run natively on the PS3 without the need for an existing jailbreak which bypasses the signature check. However, beyond the implications of this feat how did the fail0verflow team accomplish the impossible task of reverse engineering a private key from publicly available data? The answer lies in Sony’s botched implementation of Elliptic Curve Digital Signature Algorithm (ECDSA).

Geek Speak LogoAll code which executes on the PS3 requires a valid signature in order for the hardware to allow its execution. In the case of SELF (Signed Executable and Linkable Format) executable files Sony requires a signature within the file to be present which is an ECDSA signature of the file’s header utilizing Sony’s root signing key as one of the private variables. Sony’s crucial mistake comes in their implementation of the ECDSA algorithm which requires that all signatures be calculated with some unique random number k. Instead Sony used a fixed value for k across all of their application signatures which in turn has rendered the ECDSA algorithm effectively useless.

In the case of ECDSA when the random seed k is constant across more than one signature ECDSA hashing function can be solved for the private key d in the form d = (s*k – z) / r where s, z, and r are either publicly known values or are calculated as part of the ECDSA algorithm from publicly known values.

With the private key d now known SELFs may be generated which pass the security validation on the PS3 hardware and may run as native code without restriction. Furthermore, with this method duplicated across all levels of the PS3′s security layer less scrupulous members of the community may use the same method to trivially generate the private signing keys for game encryption, firmware validation, and even the system’s bootloader.

So with PS3 custom firmwares and native homebrew already starting to show up where does Sony go from here? Only time will tell. However, looking back you can say that you fully understand how it all began.

Now you know!


[Thanks to Armin Tamzarian]
Creative Commons License

Weekend Project – Car Charging Bluetooth Headset

I’ve been driving around Minnesota breaking their law about talking on cell phones while driving for a while now.  With the advent of my home state Wisconsin doing the same now, I figure I’d better start cracking down on my wayward ways.  I used to use a bluetooth headset for a while, but one thing always kept bugging me.  Every other day or so, the headset would run out of charge while I was in the car.  I’d have to take it in to charge and more often than not, I’d forget to bring it back with me into the car.  (Same thing as lunches, paperwork, and my identification badge.) So now that I have to drive through 2 states every day, it’s about time that I start using bluetooth AND charging it in the car.

So here is what I had to work with.  I’ve been given a Jabra GN Netcom headset along with a small compact base.  There was a larger base available, but I couldn’t see the need for it.  The output on the ac adapter lists output as 5-6v with a max of 5W (6v .3A).  A car’s voltage system is 12v and I already have an adapter to USB.  Easy enough, USB operates at 5v with 500-900ma.  Quite frankly, that is close enough for me.  I simply spliced the cable onto a usb end and there we have it, success.  Now I just need to dig out the usb car adapter, mount the small base in my car with removable adhesive and I will be all set.

Usenet Download Automation

Until recently when I needed to download media, either from Usenet or torrents, I searched for it manually. This usually involved either using a web based service or an IRC channel, searching for keywords and sifting through results that include spam as well as resolutions and file-types that were not what I was looking for. After successfully downloading the files, I would then manually sort them into their respective folders in my media collection, and rename them if necessary. This was especially tedious for items released on a regular basis (such as television shows), as the process would have to be done weekly for each item.


I realized there must be an easier way.


I had already been using SABnzbd for a while, as it was the only binary newsreader I could find with support for iPhone remote management, and I have to say, I loved it. SABnzbdSABnzbd has a very clean, intuitive interface, and although it doesn’t have quite the features of applications like Newsbin, it has many addons, such as the chrome and Firefox extensions, and a number of iPhone apps. Also, SABnzbd is free, open source, and available for Windows, Mac, and Linux. All the applications that will be used in this article utilize the extensibility of SABnzbd. Some can be used without it, but much of the functionality would be lost.

Sick Beard is a program that will periodically search for specified shows on various usenet search sites. When Sick Beard finds the episodes it is looking for, it downloads the NZB file, and sends it to SABnzbd for downloading. Sick Beard also comes with a script for SABnzbd post-processing, allowing for automatic renaming and sorting of downloaded media.

SickbeardSick Beard also supports downloading of NZB files to a “black hole” folder, rather then sending them directly to SABnzbd. This allows for other applications to pick the files up for downloading. In addition to usenet download support, Sick Beard also provides some torrent support, although there would be no provided post processing script so some extra configuration would probably be required to get file renaming working properly.

CouchPotato is similar in concept to Sick Beard, only it works with movies. Simply search for a movie using the application, and select the movie you want from a list of movies matching your search query that CouchPotato pulls from IMDB. The application will then search for all the movies in your queue at specified intervals, download the NZB file, and then either send the file to SABnzbd for downloading or send the file to a “black hole” folder, similar to Sick Beard.

These programs are the best I have found for the job, but off course these are just a couple suggestions. Episodebutler offers similar functionality to Sickbeard, although I have no personal experience with this one.

Also, a completely different route to go would be simply using RSS feeds. This can cause an issue however, as reposts will be downloaded multiple times.

Install Matrox G450 and Other “Unsupported” Video Cards in Windows 7

You can find an update to this post here

While working on a co-worker’s computer today, I came across a curious problem. The computer in question was being upgraded to Windows 7, and was configured to support four monitors via two Matrox G450 PCI video cards. These cards have been around quite awhile and have been supported from Windows 2000 through Server 2008 R2, so I figured I would have no issue installing the new OS.

When all was said and done, Windows could not locate the drivers for the video cards on the installation DVD, nor could it install them via Windows Update. So, I did what any normal person would do, and headed straight for Matrox’s web site.

Much to my dismay they did not seem to have any drivers listed for these cards for Windows 7. The closest I could come to the proper drivers was this set of WHQL drivers meant for Windows Server 2008 x64 and Server 2008 R2. When I tried installing the drivers, my video cards were detected properly, but the installer simply could not finish the job. Each time I tried, the installer would fail.

I went through the standard procedure of attempting to update the driver via the Device Manager, only to be told that no better driver could be found. Even when I selected to locate the driver myself and picked the folder where the Matrox installer had extracted all of its files, I simply could not install the driver.

I returned to the Device Manager and selected to update my drivers once again. I chose to locate the driver on my own, but instead of simply picking the folder this time around, I clicked “Let me pick from a list of device drivers on my computer”. From that dialog window, I clicked the “Have Disk” button and again browsed to the folder where the Matrox installer extracted its files. I looked through the list of .inf files in the directory and one caught my eye – it was named W7G4G5.inf. I opened the file in a text editor to take a look around, and after poking around for a few moments, I knew I had the file I wanted. The file’s name signified that it was meant for all G4XX and G5XX Matrox cards running under Windows 7.

I selected the file and clicked OK. The Windows Hardware wizard presented a box asking me to pick between the Matrox G450 PCI card and the Matrox G450 PCI card. Decisions, decisions. In the end, I picked the first card in the list and let Windows do its thing. Everything installed properly and I was on my way.

The whole process is actually quite simple, but for the uninitiated, it can be a daunting problem. I imagine that most people would end up digging around online looking for a driver pack that does not exist, so hopefully this saves somebody a bit of hair pulling and a lot of time. I really have no idea why the installer comes packaged with the proper Windows 7 drivers, but is unable to actually install the software. Either way, it’s an easy fix.

Follow Geek Republic
Categories